Page 5 of 5 FirstFirst ... 345
Results 41 to 44 of 44

Thread: Oil Pump Spring

  1. #41
    Join Date
    Nov 2010
    Posts
    127

    Default

    Final report on this . I put the stock oil pump back on , plus solid lifters . Bike runs great ! NO smoke ! Sending the oil pump back to S&S for checking . Will post the findings .

  2. #42
    Join Date
    Nov 2010
    Posts
    127

    Default

    Well this is the final , FINAL report on this . I sent the pump back to S&S . They tested it & said it was good . They then said they got in touch with an old tech that worked at Harley .
    He said that " stock crankcase surfaces change over time & are not as flat . Then when you install the billet pump it causes weird things to happen . He has seen this happen before ".
    They also said that they were sending the pump back to me ( saying , "you might be able to use it on a future build " ) , along with a check for " FULL reimbursement " ( $ 466.48 , purchased on ebay ) !! I thought that was incredible !!!! S&S has my business forever !!
    I am still running the bike with the stock pump as stated in the prior thread & is still running great ( knock on wood ) . Thanks again for everyone's help .

  3. #43
    Join Date
    Dec 2009
    Location
    Upstate NY
    Posts
    130

    Default

    And congratulations to you, Mike! Perseverance pays off!!!!

  4. #44
    Join Date
    Nov 2018
    Location
    Reno NV
    Posts
    270

    Default

    Quote Originally Posted by 1970 XLCH View Post
    Well this is the final , FINAL report on this . I sent the pump back to S&S . They tested it & said it was good . They then said they got in touch with an old tech that worked at Harley .
    He said that " stock crankcase surfaces change over time & are not as flat . Then when you install the billet pump it causes weird things to happen . He has seen this happen before ".
    They also said that they were sending the pump back to me ( saying , "you might be able to use it on a future build " ) , along with a check for " FULL reimbursement " ( $ 466.48 , purchased on ebay ) !! I thought that was incredible !!!! S&S has my business forever !!
    I am still running the bike with the stock pump as stated in the prior thread & is still running great ( knock on wood ) . Thanks again for everyone's help .
    I have used S&S products for years. Good products and now, exceptional customer service. Good luck.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •